Create an EasyBuilder Pro Project

3. Create an EasyBuilder Pro

Project

This chapter explains the basic steps to create an EasyBuilder Pro project.
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3.1. Overview

The following is the process of creating a project.
1. Create a new project file.

2. Save and compile the project file.

3. Run On-line or Off-line simulation.

4. Download the project file to HMI.

The following describes each process.
E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.2. Create a New Project File

1. Launch EasyBuilder Pro and open a new project file.

2. Select a model and select [Use template] check box.

‘ ~© Nev New Project

‘7 i Model: | 4 @B iP Series -
MTE051iP (480 x 272) i
MT8051iP (480 x 272)
MT6071iP/MT8071iP (800 x 480)
MT6103iP (1024 x 600)
MT8102iP (1024 x 600)
MT6102iQ (1024 x 600)

4 @ eMT Series
€MT3070 (800 x 480)
£eMT3105 (800 x 600) i Orientation

e RIS
4 B iE Series i

MTBOSOIE (480 x 272) [ Portrait
MT6O70iE (800 x 480)
MT6071iE (800 x 480)
MTB070iE/MT8100iE (800 x 480)
MT8071iE/MT8101iE (800 x 480)
MTBO73iE (800 x 480)

m

eMT3105

[¥] Use template (template_800x600.emtp)

[Unccmpress Prcject] 1& Demo Prcjé(t]

3. Click [New] button in the Device tab and select a device.
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< | m

o
System Parameter Settings (=]
| Printex/Backup Server [ Time Syne /DST ] e-Mail | Recipes | Cellular Data Network
Device | Model | General | SysemgSetting | Security | Non-ASCIIFonts | Extended Memory
Device list : What's my IP ?
Name Location Device type Interface I/F Protocol

(3 Local HMI Local HMI lLocal  [em73105(800..[- [ |

[ New... ] [ Delete ] [ Security... ]
4. Configure parameters.
Device Properties
MName @ Mitsubishi FX0S/FX0M/FX15/FX1N/FX2
) HMI @ PLC
PLC type : [ Mitsubishi FEOM/FXON/FLLSFH L N/FH2 | » ]
IV.1.4U, MITSUBISHI_FXOM.e30
PLCIF : [Rs5485 4w -
* Support communications between HMI and PLC in pass-through mode
* Get LW-9903 to 2 to enhance the speed of download/upload PLC program in pass-through mode
COM : [COM1 (9600,E,7,1) Settings...
PLC default station no. : o
[ Default station no. use station no. variable
[T Use broadcast command
Interval of block pack (words) : E
Max. read-command size (words) @ |32
Max. write-command size (words) : |32
I 0K ] l Cancel
5. A new device is added to the [Device List].
 System Parameter Settings ’
Printer/Backup Server | TimeSync/DST |  e-Masil | Recipes |  Cellular Data Network
Device | Model | Genersl | SystemSetting | Security | Non-ASCIIFonts | Extended Memory
Device list : What's my IP ?
No. Name Location  Device type Interface IIF Protocol
Locall-lm ~ Local HMI Local eMT3105 (800 ... -
8 Local PLC 1 | Mitsubishi FXO... Mitsubishi FX0... |COM 1 (9600,E... |RS485 4W
6. Create an object, for example, a Toggle Switch, and then set the address.
| ‘I WE!NTEK EasyBuilder Pro V6.09.01
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New Toggle Switch/Bit Lamp Object

General | Security | Shape | Label |

Comment :

) BitLamp

[V Read /Write vse d.
Read address

@ Toggle Switch

ifferent addresses

v |[ Settings...

PLC: [Mimbi.shi FEOSFEONFEISFEINFEZ

Address: [x

~|0

[ Invert signal

Write address :

PLC: [Miwubis]ﬁ FEOS/FEON/FXISFEINFEZ

v |[ Seftings...

Address : [Y

v]0 \'

Attribute

[] Write when button is released

7. Place the object in the edit window. A project is now created.

EasyBuilder Pro : EBProjectl - [10 - WINDOW,_010]
File H = « » ; RS Object

B 2B MF

Project
Yo lAHEm-
[="1
Paste System 28+2E B =
Parameters - Yaelcit
Editing Object

Data/History ~ View

Clipboard

Tool

Arrange

AdobeDevanagari: ~

A 7 A

= A

Font

1

5

[ ][5 ]

- 8 X &

S1|S2 s3 s4|1
L1 12 13 141

State/Language

Windows v X { 10 - WINDOW_ 010 X

bttt -
i 3 : Fast Selection

4: Common Window @
. 5:PLC Response

6 : HMI Connection

7 : Password Restriction

8 : Storage Space Insufficient
9 : Backup
- *10 : WINDOW_010

e [

|G re—— |

>

rmu ]mo |znu |wn |\
Sk Bt b bbb b B b bt b b b e b b b bbb b Db b bbb b bt

— / |
[Address | windows [Web |

m

i v v S0 v e 0 280 v v i ol 0 v 88 s 8wl

m

3.3. Save and Compile the Project File

1. In EasyBuilder Pro toolbar click [File] » [Save] to save the .emtp file.

2. In EasyBuilder Pro toolbar click [Project] » [Compile] to compile .emtp file as .exob file,
which could be downloaded to HMI. This also checks if the project can run correctly.

D‘pWE!NTEK

EasyBuilder Pro V6.09.01
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0 Note

B  For cMT / cMT X Series models, the project file extension is .cmtp, and the compiled file
extension is .cxob.

3. To use multiple languages, all languages must be configured in Label Tag Library first.
When downloading the project to HMI, select the needed languages only. A successful

compilation is shown in the following figure.

Compile IEI

Project name : C:\Jsers\Janecheng'Desktop\EBProjectl.cmip

CXOB file name : C:\Users\Janecheng\Desktop\EBProject1. cxob

CXOB password : (used in decompiler)

[ becompilation is prohibited [ Disable HMI upload function

Select the languages used on the HMI

Startup language after redownloading the project : |Language 1 -

Language 1

Treat the use of unsupported tags as :

Double-dick a message to modify the attributes of the object in question

Quick Compile l Font Management... J [T Build font files

3.4. Compile and Quick Compile

The [Compile] and [Quick Compile] modes can be selected in the Compile window. To compile
a relatively large file in which only a few windows are modified, the Quick Compile mode can
be used to save compilation time.

Compile:

Compile the whole project file.

Quick Compile:

Only compile the modified window or event log. When one of the records in the event log is
changed, the whole event log will be compiled.

I__| WE!NTEK EasyBuilder Pro V6.09.01
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0 Note

B [f the project file is compiled for the first time, the Quick Compile mode is not supported.

B |n a project file, when its system settings, picture library, sound library, or label library is
modified, then Quick Compile mode is not supported for the first compilation after
modification.

B The whole project file must be compiled before it is downloaded to HMI.

B Utility Manager does not support the project file compiled using Quick Compile mode. To

download a project file using Utility Manager, please compile the whole project file first.

3.5. Run On-Line or Off-Line Simulation
FII!
pX

— Off-line simulation: Simulate project operation on PC without the need for connecting
any device.

FII!

'— On-line simulation: Simulate project operation on PC without downloading the project
to HMI. The PLC is connected to PC, please set correct parameters.

0 Note

M (iE/XE/eMT Series) When using On-line Simulation on PC, if the target device is the PLC
directly connected to PC, there is a 10-minute simulation limit.
B (cMT/cMT X Series) When using On-line Simulation on PC, the monitoring time is limited

to one hour and a prompt window pops up every 15 minutes.

3.6. cMT Viewer

This program connects to cMT Series models via network. To run this program, execute
cMTViewer.exe under installation directory. Or, in EasyBuilder Pro toolbar, click [Tools] » [cMT
Viewer].

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.

I__| WE!NTEK EasyBuilder Pro V6.09.01
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2017-02-09 19:21:24

3.7. Download the Project File to HMI

The following explains four ways to download the project file to HMI.

@ Note

B For cMT-SVR, only the way described in 3.6.1 is available.
B When download project file to HMI using mini USB cable, please do not connect PLC
simultaneously, in order to avoid noise from PLC interfering with HMI.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.7.1. Configure in EasyBuilder Pro

1. In EasyBuilder Pro toolbar, click [Project] » [Download]. Make sure that all the settings are
correct.
2. Select [Ethernet], set password and HMI IP.
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eMT, iE, XE, mTV Series

Download (PC->HMI)

=

Fassword/Port no. of download/upload

(@ Ethernet

4 2 P HMI Name 4
IP: 10.7.139.86 hd
[V]Font files [/] Use EasyAccess 2.0 What's my [P7

[] Diagnostic tool

[V]Runtime  * Necessary if update runtime or execute download first time.

[ ] Use user-defined startup screen

[ use system settings file

Synchronize HMI clock with PC

[T Delete user-defined startup screen

[T Reset recipe (RW, RW_A) [T] Reseteventlog

[T] Reset recipe database [] Reset operation log

[] Reset data sampling
[C] Reset string table

[/]Reboot HMI after download
["] Automatically using current settings to download after compiling

cMT, cMT X Series

Download (PC->HMI)

@) Ethernet

4 7 IP HMI Name

IP: 1071

Froject Checksum : 9ee5836c3331ab235f69a5a011d7e5h7

[ Runtime = Necessary if update runtime or execute download first time.

[ Use system settings file

Synchronize HMI clock with PC
[] Reset racipe (RW, RW_A)
[ Reset recipe database

["] Automatically using current settings to download after compiling

39.86 -

[] Reset event log
[C] Reset operation log
[] Reset PRW on HML

Password/Fort no. of download/upload :

'3

What's my [P7

[] Reset data sampling
[ Reset string table
and all cMT Viewers

o0 e ) bowrosd | swp
Setting Description

Font files

Download the font used in the project to HMI.

Runtime

Select the check box to update the HMI kernel

programs. If this is the first time downloading file or

EasyBuilder Pro version is updated, please download

the firmware before downloading files to HMI.

EasyAccess 2.0

Download EasyAccess 2.0 driver to HMI. (This option

is available only for MT8000iE models. For other

models, EasyAccess 2.0 will be automatically

downloaded.)

Use user-defined
startup screen

Download the specified .bmp image file to the HMI

as the startup screen. For cMT/cMT X HMI, please

see chapter 5.4 General Settings in this user manual

for more information on updating the startup screen
on the HMI.

Use system settings
file

hardware settings.

Download the system settings file to update

Synchronize HMI
clock with PC

downloading project file.

Synchronize HMI time with PC time when

Delete existing user
accounts, e-Mail
contacts and SMTP
settings

Select the check box to delete existing user
accounts, e-Mail contacts or SMTP settings before

downloading the project. This setting is only

effective when one of the following settings is

I__| WE!NTEK
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enabled:

1. [System Parameters] » [Security] » [Enhanced
security mode] » [Use existing user accounts on
HMI first (if existed), Othrewise, use settings
below].

2. [System Parameter s] » [e-Mail] » [Use existing
user accounts on HMI first (if existed),

Othrewise, use settings below].

Reset recipe/

event log/

data sampling/ ) .

recipe database/ The selected files will be erased before
operation log/ downloading.

string table/
user-defined
startup screen

Reboot HMI after HMI will reboot after the downloading process is
download

done.

Automatically
using current
settings to to the latest target HMI. The way to enable this
download after
compiling

The system will compile the project and download it

function is described in the following part.

[Automatically using current settings to download after compiling]

If this check box is selected, EasyBuilder Pro will compile the project and download it to the
latest target HMI.

1. In EasyBuilder Pro toolbar, click [File] » [Preferences].

2. Select [Automatic save and compile when download and simulate] check box.

I__| WE!NTEK EasyBuilder Pro V6.09.01
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Preference
Project
Displ [¥] Automatically save and compile the project when download and simulate
isplay
Grid [7] Generate backup of project file before save
Library [] Automatically make used pictures and shapes into the project library

[7] save AutoRecover information

[ OK J [ Cancel

3. In EasyBuilder Pro toolbar, click [Save] and then [Download)].

4. In the dialog box, select [Automatically using current settings to download after compiling]
check box.

5. Click [Download].

6. When finished, next time when [Download] is clicked, EasyBuilder Pro will automatically

compile and download the project to the latest target HMI.
3.7.2. Use HMI Name

1. Go to [System settings] on HMI and then set HMI name first.

.Srstern settings

Network\ TimefDate" Securit  HMI name\getting\gg\

HMI namel

iCancel | | Apply | ioK !

I__| WE!NTEK EasyBuilder Pro V6.09.01
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2. OnPC, select the HMI name and start downloading. To use [Search], enter the HMI name

first to search for the HMI. [Search all] searches for all HMIs in the same subnet network.

Download (==
© Ethernet Password/Port no. of download/upload :
4 s /" 1P”" HMIName 3
HMI: ie7 v

Search All

[Z]Font files [V] Use EasyAccess 2.0 What's sy IP?
[¥|Runtime *Necessary if update runtime or execute download first time.

[ Use user-defined startup screen

[7] Use system settings file

[¥] synchronize HMI dlock with PC

[7] Delete user-defined startup screen
[7]Reset recipe [V|Reset event log [V|Reset data sampling

[¥] Reset recipe database [7|Reset operation log [V|Reset string table

[?]Reboot HMI after download
[ Automatically using current settings to download after compiling

I__| WE!NTEK EasyBuilder Pro V6.09.01
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3.7.3. Use USB cable

P

Download @

@) USB cable Password : | Settings...

[¥|Font files

[¥|Runtime *Necessary if update runtime or execute download first time,

[ Use user-defined startup screen

[ Use system settings file

[ Delete user-defined startup screen

[7]Reset recipe [V|Reset event log [V] Reset data sampling
[V]Reset recipe database [7|Reset operation log [V]Reset string table
[7]Reboot HMI after download

|| Automatically using current settings to download after compiling

| Download Stop Exit

Select USB cable to download project to HMI. The way of setting is same as “3.6.1 Configure in

EasyBuilder Pro”. Before downloading via USB cable, please make sure the USB driver is

installed. Go to [Computer Management] » [Device Manager] to check if USB driver is installed.

If it is not installed, please refer to to install manually.

3.7.4. Use USB Drive or SD Card

The following explains how to download project file by using USB drive or SD card.
1.  On EasyBuilder Pro toolbar click [Project] » [Build for SD card / USB disk download].

Browse for the project file and then click [Build], the file for download will be generated in
the connected external device.

I__| WE!NTEK EasyBuilder Pro V6.09.01
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USB Disk/CF Card/SD Card Data (==

Select the folder to save download data :

o

Use system setting (OS5 version 20131106 or later supports only)

System setting file location :

[ Build ] [ System Settings...
2. Insert an external device to HMI.
3. Select [Download] on HMI and enter password.
Download/Upload
— Powniosd settngs |4
Upload Password: ||
Restart project and exit ‘
¥ Download project files
Load System Setting |7 Download history files
cancel l_ Clear history files
Stop after download/upload Cancel
Time remaining 4

4. After password is confirmed, it will show the directories in the external device. (pccard: SD
Card; usbdisk: USB Drive)

[Pick apirectery PA
Directory: Jusbdisle/disk_a_1
M3 pccard
Fusbdisk
isk a 1
yMt8000ie

oK /‘r Cancel

5. Select the directory that contains project, and then click [OK] to start downloading.

I__| WE!NTEK EasyBuilder Pro V6.09.01
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@ Note

B Please select the parent directory of the generated files when downloading. For the
structure above, please select disk_a_1, not mt8000ie.

B You may click [System Settings] to save the hardware settings configured in EasyBuilder
Pro into SD card or USB disk, and then download the settings file to HMI. See “4 Hardware
Settings” for more information.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.

3.8. Upload the Project File from HMI

1. On EasyBuilder Pro toolbar click [File] » [Upload].
2. Set HMI IP, HMI model, project location and project name, and then click [Upload].

Upload @I
@ Ethernet ) USB cable Password/Port no. of download/upload :
4 P Name I
IP:  192.168.1.100 -
What's moy [P 7
HMI model : | eMT3070 -
Project location : C:\EMTP1.exob
I__| WE!NTEK EasyBuilder Pro V6.09.01
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